CVE-2026-103039 Gravity Forms - Insecure Deserialization

Gravity Forms plugin for WordPress <= 3.1.2 contains a PHP Object Injection caused by unsafe unserialization in GFFormsModel::create_post(), letting unauthenticated attackers inject PHP objects into post meta, exploit requires presence of vulnerable gadget chains in plugins/themes or WordPress environment.

CVSS base score 9.8 /10
Critical
CISA KEV
Exploited in the wild
Public exploit
Proof of concept available
Authentication
Not required
EPSS
0.51% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Insecure Deserialization
Impact
Remote Code Execution
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-502

Vendor fix

Update to Gravity Forms version later than 3.1.2 or the latest available version.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs