CVE-2026-105894 Ak Framework WordPress Plugin - Privilege Escalation

Ak Framework plugin for WordPress <= 2.9.8 contains a privilege escalation caused by missing capability checks in ajax_refresh_nonce and ak_admin_ajax handlers, letting unauthenticated attackers update arbitrary options to escalate privileges.

CVSS base score 8.8 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
EPSS
0.32% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Privilege Escalation
Impact
Privilege Escalation
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-269

Vendor fix

Update to a version later than 2.9.8 or the latest available version.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs