CVE-2026-107685 req_llm - Improper Certificate Validation

req_llm 1.9.0 to < 1.29.0 contains an improper certificate validation caused by WebSockex client defaulting to insecure TLS options, letting on-path attackers read and modify OpenAI WebSocket sessions including authorization tokens, exploit requires attacker to be on the network path.

CVSS base score 9.1 /10
Critical
CISA KEV
Not listed
Public exploit
None known
EPSS
0.34% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Improper Certificate Validation
Impact
Information Disclosure, Data Tampering
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
23 October 2026
Updated
25 October 2026
Weakness
CWE-295

Vendor fix

Update to version 1.29.0 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs