---
title: "CVE-2026-107685: req_llm - Improper Certificate Validation"
description: "req_llm 1.9.0 to < 1.29.0 contains an improper certificate validation caused by WebSockex client defaulting to insecure TLS options, letting on-path attackers read and modify OpenAI WebSocket sessions including authorization tokens, exploit requires attacker to be on the network path."
url: https://panop.io/threat-heartbeat/CVE-2026-107685/
---

# CVE-2026-107685 req\_llm - Improper Certificate Validation

req\_llm 1.9.0 to < 1.29.0 contains an improper certificate validation caused by WebSockex client defaulting to insecure TLS options, letting on-path attackers read and modify OpenAI WebSocket sessions including authorization tokens, exploit requires attacker to be on the network path.

CVSS base score 9.1 /10

Critical

CISA KEV

Not listed

Public exploit

None known

EPSS

0.34% chance of exploitation in 30 days

[View the NVD record ↗](https://nvd.nist.gov/vuln/detail/CVE-2026-107685)

## Details

Type

Improper Certificate Validation

Impact

Information Disclosure, Data Tampering

CVSS vector

CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Published

23 October 2026

Updated

25 October 2026

Weakness

[CWE-295](https://cwe.mitre.org/data/definitions/295.html)

## Vendor fix

Update to version 1.29.0 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

## References

- [https://nvd.nist.gov/vuln/detail/CVE-2026-107685](https://nvd.nist.gov/vuln/detail/CVE-2026-107685)
- [https://cna.erlef.org/cves/CVE-2026-107685.html](https://cna.erlef.org/cves/CVE-2026-107685.html)
- [https://github.com/agentjido/req\_llm/commit/a389d718640ceb2d541a8f540ab954cbf5ef8313](https://github.com/agentjido/req_llm/commit/a389d718640ceb2d541a8f540ab954cbf5ef8313)
- [https://github.com/agentjido/req\_llm/commit/c7264fc0217fbacfb5562234ff790b8e4462de76](https://github.com/agentjido/req_llm/commit/c7264fc0217fbacfb5562234ff790b8e4462de76)
- [https://github.com/agentjido/req\_llm/security/advisories/GHSA-6vww-5m28-f26v](https://github.com/agentjido/req_llm/security/advisories/GHSA-6vww-5m28-f26v)
- [https://osv.dev/vulnerability/EEF-CVE-2026-107685](https://osv.dev/vulnerability/EEF-CVE-2026-107685)

[← All CVEs](https://panop.io/threat-heartbeat/)

## What this record can't tell you

- Whether you run the affected software, and where
- Whether an attacker can actually reach and exploit it
- The misconfigurations that never get a CVE number
- What it would cost the business, ranked into what to fix first

Panop answers these inside your environment, for this CVE and every other finding.

[Book a demo](https://panop.io/demo)
