CVE-2026-108358 PhpSpreadsheet - XML External Entity Injection

PhpSpreadsheet < 1.30.7, 2.1.19, 2.4.8, 3.10.8, and 5.10.0 contains an XML external entity injection caused by improper DOCTYPE detection in XmlScanner, letting attackers cause denial of service, local file access, or SSRF via crafted XLSX files, exploit requires processing attacker-controlled XLSX files.

CVSS base score 8.8 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
View the NVD record ↗

Details

Type
XML External Entity Injection
Impact
Denial Of Service, File System Read, Server Side Request Forgery
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:H/SC:L/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
22 October 2026
Updated
23 October 2026
Weakness
CWE-611

Vendor fix

Update to versions 1.30.7, 2.1.19, 2.4.8, 3.10.8, or 5.10.0 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs