CVE-2026-109090 libXi - Buffer Overflow

libXi < 1.8.4 contains a heap overflow caused by processing a large DEVICE_ENABLE reply from a malicious X server, letting attackers cause memory corruption remotely, exploit requires a malicious X server.

CVSS base score 7.5 /10
High
CISA KEV
Not listed
Public exploit
None known
EPSS
0.26% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Buffer Overflow
Impact
Remote Code Execution
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Published
27 October 2026
Updated
29 October 2026
Weakness
CWE-122

Vendor fix

Update to version 1.8.4 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs