---
title: "CVE-2026-109090: libXi - Buffer Overflow"
description: "libXi < 1.8.4 contains a heap overflow caused by processing a large DEVICE_ENABLE reply from a malicious X server, letting attackers cause memory corruption remotely, exploit requires a malicious X server."
url: https://panop.io/threat-heartbeat/CVE-2026-109090/
---

# CVE-2026-109090 libXi - Buffer Overflow

libXi < 1.8.4 contains a heap overflow caused by processing a large DEVICE\_ENABLE reply from a malicious X server, letting attackers cause memory corruption remotely, exploit requires a malicious X server.

CVSS base score 7.5 /10

High

CISA KEV

Not listed

Public exploit

None known

EPSS

0.26% chance of exploitation in 30 days

[View the NVD record ↗](https://nvd.nist.gov/vuln/detail/CVE-2026-109090)

## Details

Type

Buffer Overflow

Impact

Remote Code Execution

CVSS vector

CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H

Published

27 October 2026

Updated

29 October 2026

Weakness

[CWE-122](https://cwe.mitre.org/data/definitions/122.html)

## Vendor fix

Update to version 1.8.4 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

## References

- [https://nvd.nist.gov/vuln/detail/CVE-2026-109090](https://nvd.nist.gov/vuln/detail/CVE-2026-109090)
- [https://gitlab.freedesktop.org/xorg/lib/libxi/-/commit/4eb9f70b6](https://gitlab.freedesktop.org/xorg/lib/libxi/-/commit/4eb9f70b6)

[← All CVEs](https://panop.io/threat-heartbeat/)

## What this record can't tell you

- Whether you run the affected software, and where
- Whether an attacker can actually reach and exploit it
- The misconfigurations that never get a CVE number
- What it would cost the business, ranked into what to fix first

Panop answers these inside your environment, for this CVE and every other finding.

[Book a demo](https://panop.io/demo)
