---
title: "CVE-2026-109381: Mage Eventpress - Privilege Escalation"
description: "Mage Eventpress plugin for WordPress <= 5.7.8 contains a privilege escalation caused by unvalidated mep_grant_shop_manager_access() function hooking user_has_cap, letting authenticated Shop Manager-level attackers escalate to Administrator by manipulating the page parameter."
url: https://panop.io/threat-heartbeat/CVE-2026-109381/
---

# CVE-2026-109381 Mage Eventpress - Privilege Escalation

Mage Eventpress plugin for WordPress <= 5.7.8 contains a privilege escalation caused by unvalidated mep\_grant\_shop\_manager\_access() function hooking user\_has\_cap, letting authenticated Shop Manager-level attackers escalate to Administrator by manipulating the page parameter.

CVSS base score 7.2 /10

High

CISA KEV

Not listed

Public exploit

None known

Authentication

Required

EPSS

0.43% chance of exploitation in 30 days

[View the NVD record ↗](https://nvd.nist.gov/vuln/detail/CVE-2026-109381)

## Details

Type

Privilege Escalation

Impact

Privilege Escalation

CVSS vector

CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H

Published

28 October 2026

Updated

29 October 2026

Weakness

[CWE-269](https://cwe.mitre.org/data/definitions/269.html)

## Vendor fix

Update to a version later than 5.7.8 or the latest available version.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

## References

- [https://nvd.nist.gov/vuln/detail/CVE-2026-109381](https://nvd.nist.gov/vuln/detail/CVE-2026-109381)
- [https://github.com/magepeopleteam/mage-eventpress](https://github.com/magepeopleteam/mage-eventpress)
- [https://plugins.trac.wordpress.org/browser/mage-eventpress/trunk/woocommerce-event-press.php#L405](https://plugins.trac.wordpress.org/browser/mage-eventpress/trunk/woocommerce-event-press.php#L405)
- [https://plugins.trac.wordpress.org/browser/mage-eventpress/trunk/woocommerce-event-press.php#L432](https://plugins.trac.wordpress.org/browser/mage-eventpress/trunk/woocommerce-event-press.php#L432)
- [https://plugins.trac.wordpress.org/browser/mage-eventpress/trunk/woocommerce-event-press.php#L504](https://plugins.trac.wordpress.org/browser/mage-eventpress/trunk/woocommerce-event-press.php#L504)
- [https://plugins.trac.wordpress.org/changeset/3754150/mage-eventpress/trunk/woocommerce-event-press.php](https://plugins.trac.wordpress.org/changeset/3754150/mage-eventpress/trunk/woocommerce-event-press.php)
- [https://www.wordfence.com/threat-intel/vulnerabilities/id/076607ec-d848-4b4e-986b-31287f8f0ae4?source=cve](https://www.wordfence.com/threat-intel/vulnerabilities/id/076607ec-d848-4b4e-986b-31287f8f0ae4?source=cve)

[← All CVEs](https://panop.io/threat-heartbeat/)

## What this record can't tell you

- Whether you run the affected software, and where
- Whether an attacker can actually reach and exploit it
- The misconfigurations that never get a CVE number
- What it would cost the business, ranked into what to fix first

Panop answers these inside your environment, for this CVE and every other finding.

[Book a demo](https://panop.io/demo)
