CVE-2026-109987 PixelYourSite WordPress Plugin - Stored XSS

PixelYourSite WordPress plugin < 11.4.3 and PixelYourSite Pro WordPress plugin < 12.6.8 contain a stored XSS caused by unsanitized cookie values printed into page output, letting unauthenticated attackers execute scripts via cached pages.

CVSS base score 7.2 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
EPSS
0.17% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Stored XSS
Impact
Stored XSS
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Published
22 October 2026
Updated
23 October 2026
Weakness
CWE-79

Vendor fix

Upgrade PixelYourSite to version 11.4.3 or later and PixelYourSite Pro to version 12.6.8 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs