CVE-2026-110354 HAProxy - Denial of Service

HAProxy < 3.4.6 contains a denial of service caused by improper handling of HTTP/1.1 chunked requests in the H1 multiplexer, letting remote unauthenticated attackers exhaust CPU and worker threads, exploit requires crafted chunked requests.

CVSS base score 7.5 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
EPSS
0.76% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Denial of Service
Impact
Denial Of Service
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
22 October 2026
Updated
23 October 2026
Weakness
CWE-835

Vendor fix

Upgrade to version 3.4.6 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs