CVE-2026-111089 Apache Wicket - Stored XSS

Apache Wicket 8.0.0 through 8.19.0, 9.0.0 through 9.24.0, and 10.0.0 through 10.11.0 contain a stored XSS caused by unescaped texts in JavaScript string literals and attribute values in resource bundles, letting attackers inject script in the application's origin, exploit requires attacker-controlled resource bundle entries.

CVSS base score 7.6 /10
High
CISA KEV
Not listed
Public exploit
None known
View the NVD record ↗

Details

Type
Stored XSS
Impact
Stored XSS
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
1 November 2026
Updated
3 November 2026
Weakness
CWE-79

Vendor fix

Upgrade to Apache Wicket versions 8.20.0, 9.25.0, or 10.12.0 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs