CVE-2026-111497 Google Brotli - Buffer Overflow

Google Brotli 1.0.3 through 1.2.0 contains a buffer overflow caused by improper handling in the decoder component, letting remote unauthenticated attackers corrupt memory, disclose data, cause DoS, or execute code using crafted Brotli streams.

CVSS base score 9.2 /10
Critical
CISA KEV
Not listed
Public exploit
Proof of concept available
Authentication
Not required
View the NVD record ↗

Details

Type
Buffer Overflow
Impact
Remote Code Execution, Information Disclosure, Denial Of Service
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
22 October 2026
Updated
23 October 2026
Weakness
CWE-252

Vendor fix

Update to version 1.0.10, 1.1.1, 1.2.1 or latest available version.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs