---
title: "CVE-2026-112816: Canonical LXD - Authentication Bypass"
description: "Canonical LXD < 4.0.15, < 5.0.11, < 5.21.9, < 6.10.1 contains an authentication bypass caused by improper certificate validation in the HTTPS listener, letting unauthenticated attackers authenticate as any trusted client and gain full cluster access, exploit requires crafted certificate chain."
url: https://panop.io/threat-heartbeat/CVE-2026-112816/
---

# CVE-2026-112816 Canonical LXD - Authentication Bypass

Canonical LXD < 4.0.15, < 5.0.11, < 5.21.9, < 6.10.1 contains an authentication bypass caused by improper certificate validation in the HTTPS listener, letting unauthenticated attackers authenticate as any trusted client and gain full cluster access, exploit requires crafted certificate chain.

CVSS base score 10.0 /10

Critical

CISA KEV

Not listed

Public exploit

Proof of concept available

EPSS

0.30% chance of exploitation in 30 days

[View the NVD record ↗](https://nvd.nist.gov/vuln/detail/CVE-2026-112816)

## Details

Type

Authentication Bypass

Impact

Privilege Escalation

CVSS vector

CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X

Published

30 October 2026

Updated

1 November 2026

Weakness

[CWE-295](https://cwe.mitre.org/data/definitions/295.html)

## Vendor fix

Update to versions 4.0.15, 5.0.11, 5.21.9, 6.10.1 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

## References

- [https://nvd.nist.gov/vuln/detail/CVE-2026-112816](https://nvd.nist.gov/vuln/detail/CVE-2026-112816)
- [https://discourse.ubuntu.com/t/lxd-5-21-9-lts-has-been-released/90565/1](https://discourse.ubuntu.com/t/lxd-5-21-9-lts-has-been-released/90565/1)
- [https://discourse.ubuntu.com/t/lxd-6-10-1-lts-has-been-released/90024](https://discourse.ubuntu.com/t/lxd-6-10-1-lts-has-been-released/90024)
- [https://discourse.ubuntu.com/t/security-advisory-critical-vulnerability-found-in-canonical-lxd-and-microcloud/90557](https://discourse.ubuntu.com/t/security-advisory-critical-vulnerability-found-in-canonical-lxd-and-microcloud/90557)
- [https://github.com/canonical/lxd/security/advisories/GHSA-99jp-jwmc-65p4](https://github.com/canonical/lxd/security/advisories/GHSA-99jp-jwmc-65p4)
- [https://discourse.ubuntu.com/t/lxd-4-0-15-lts-has-been-released/90571](https://discourse.ubuntu.com/t/lxd-4-0-15-lts-has-been-released/90571)
- [https://discourse.ubuntu.com/t/lxd-5-0-11-lts-has-been-released/90570/1](https://discourse.ubuntu.com/t/lxd-5-0-11-lts-has-been-released/90570/1)

[← All CVEs](https://panop.io/threat-heartbeat/)

## What this record can't tell you

- Whether you run the affected software, and where
- Whether an attacker can actually reach and exploit it
- The misconfigurations that never get a CVE number
- What it would cost the business, ranked into what to fix first

Panop answers these inside your environment, for this CVE and every other finding.

[Book a demo](https://panop.io/demo)
