CVE-2026-114422 Enable Media Replace WordPress - Insecure Deserialization

Enable Media Replace WordPress plugin < 4.2.3 contains a PHP Object Injection caused by unrestricted classes during deserialization in media replace-and-update-links routine, letting unauthenticated attackers escalate to remote code execution if attacker-controlled PHP/HTML files exist, exploit requires user with upload access to perform media replacement.

CVSS base score 7.5 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
EPSS
0.82% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Insecure Deserialization
Impact
Remote Code Execution
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H
Published
30 October 2026
Updated
31 October 2026
Weakness
CWE-502

Vendor fix

Update to version 4.2.3 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs