CVE-2026-114663 Vyper - Logic Corruption

Vyper 0.4.0b1 through 0.5.0b1 contains a logic corruption vulnerability caused by miscompilation of unfoldable constants and omitted default arguments in imported modules, letting attackers manipulate values to corrupt validation or accounting logic, exploit requires attacker-controlled input with conflicting variable names.

CVSS base score 8.4 /10
High
CISA KEV
Not listed
Public exploit
None known
EPSS
0.14% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Logic Corruption
Impact
Data Tampering
CVSS vector
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
22 October 2026
Updated
23 October 2026
Weakness
CWE-706

Vendor fix

Update to a version later than 0.5.0b1 or the latest available version.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs