CVE-2026-115506 libexpat - Denial of Service

libexpat through 2.9.0 contains a denial of service vulnerability caused by late detection of entity amplification in accountingDiffTolerated() in xmlparse.c, letting attackers consume excessive CPU by supplying crafted XML with nested entity expansions.

CVSS base score 7.5 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
View the NVD record ↗

Details

Type
Denial of Service
Impact
Denial Of Service
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
22 October 2026
Updated
23 October 2026
Weakness
CWE-776

Vendor fix

Update to the latest version beyond 2.9.0.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs