CVE-2026-115586 virtualenv - Command Injection

virtualenv 21.14.9 to 21.14.13 contains a command injection caused by unescaped --prompt value in bash bin/activate script when promptvars and POSIX mode are disabled, letting attackers execute commands as the user activating the environment, exploit requires crafted --prompt value and specific shell settings.

CVSS base score 7.1 /10
High
CISA KEV
Not listed
Public exploit
None known
EPSS
0.19% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Command Injection
Impact
Remote Code Execution
CVSS vector
CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
23 October 2026
Updated
25 October 2026
Weakness
CWE-78

Vendor fix

Update to version 21.14.13 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs