CVE-2026-115807 User Profile Builder - Privilege Escalation

User Profile Builder WordPress plugin <= 4.0.3 contains a limited privilege escalation caused by improper role authorization in Gutenberg Register block, letting authenticated attackers with Author-level access create accounts with Editor or other privileged roles.

CVSS base score 7.1 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
EPSS
0.21% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Privilege Escalation
Impact
Privilege Escalation
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:N
Published
24 October 2026
Updated
26 October 2026
Weakness
CWE-269

Vendor fix

Update to a version later than 4.0.3 or the latest available version.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs