CVE-2026-115912 vLLM - Insecure Deserialization

vLLM < 0.32.0 contains an insecure deserialization vulnerability caused by trusting forged shared-memory address and monotonic_id values in public multimodal features.kwargs_data, letting authenticated attackers execute arbitrary Python code remotely, exploit requires authentication.

CVSS base score 7.5 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
View the NVD record ↗

Details

Type
Insecure Deserialization
Impact
Remote Code Execution
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
26 October 2026
Updated
27 October 2026
Weakness
CWE-502

Vendor fix

Upgrade to version 0.32.0 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs