CVE-2026-115915 vLLM - Command Injection

vLLM < 0.32.0 contains a command injection caused by unrestricted image decoder selection in ImageMediaIO via Image.open(BytesIO(data)), letting attackers dispatch EPS payloads to execute commands with vLLM process privileges, exploit requires vulnerable Ghostscript or Pillow dependencies.

CVSS base score 8.1 /10
High
CISA KEV
Not listed
Public exploit
None known
View the NVD record ↗

Details

Type
Command Injection
Impact
Remote Code Execution, Denial Of Service
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
26 October 2026
Updated
27 October 2026
Weakness
CWE-20

Vendor fix

Update to version 0.32.0 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs