CVE-2026-116179 vLLM - Denial of Service

vLLM >= 0.18.0 < 0.31.0 contains a resource exhaustion vulnerability caused by overriding num_frames through media_io_kwargs in VideoMediaIO.load_base64, letting API clients exhaust memory and crash the frontend, exploit requires crafted input with large inline video.

CVSS base score 7.5 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
View the NVD record ↗

Details

Type
Denial of Service
Impact
Denial Of Service
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
25 October 2026
Updated
26 October 2026
Weakness
CWE-770

Vendor fix

Update to version 0.31.0 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs