CVE-2026-116238 pgAdmin 4 - Authentication Bypass

pgAdmin 4 < 9.19 contains an authentication bypass caused by improper handling of internal account lockout and password verification in Flask-Security views, letting unauthenticated attackers perform unlimited password guesses on internal accounts, exploit requires server mode with default configuration.

CVSS base score 8.1 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
EPSS
0.40% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Authentication Bypass
Impact
Broken Authentication
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-307

Vendor fix

Upgrade to pgAdmin 4 version 9.19 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs