CVE-2026-116241 pgAdmin 4 - Command Injection

pgAdmin 4 < 9.19 contains a command injection caused by improper handling of backslashes inside double-quoted identifiers in the Import/Export Data tool, letting ordinary database roles execute OS commands, exploit requires the ability to turn off standard_conforming_strings.

CVSS base score 9.9 /10
Critical
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
EPSS
0.32% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Command Injection
Impact
Remote Code Execution
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-78

Vendor fix

Update to version 9.19 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs