CVE-2026-116243 pgAdmin 4 - Command Injection

pgAdmin 4 < 9.19 contains a command injection caused by improper validation of user-set binary paths allowing execution of arbitrary binaries from shared storage, letting authenticated users execute OS commands, exploit requires user to set binary path to malicious executable.

CVSS base score 7.5 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
EPSS
0.32% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Command Injection
Impact
Remote Code Execution
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-426

Vendor fix

Upgrade to version 9.19 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs