CVE-2026-116244 pgAdmin 4 - Authentication Bypass

pgAdmin 4 < 9.19 contains a broken authentication caused by improper handling of Kerberos delegated credentials in connection environment, letting attackers connect as the service account's Kerberos principal, exploit requires server mode or Windows SSPI usage.

CVSS base score 8.2 /10
High
CISA KEV
Not listed
Public exploit
Proof of concept available
EPSS
0.28% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Authentication Bypass
Impact
Broken Authentication
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-522

Vendor fix

Upgrade to pgAdmin 4 version 9.19 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs