CVE-2026-116245 pgAdmin 4 - Authentication Bypass

pgAdmin 4 < 9.19 contains a broken authentication caused by unrestricted use of service connection parameters in server mode, letting any user connect with credentials from service files, exploit requires server mode operation with default settings.

CVSS base score 8.2 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
EPSS
0.16% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Authentication Bypass
Impact
Privilege Escalation
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:N
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-522

Vendor fix

Update to version 9.19 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs