CVE-2026-116249 pgAdmin 4 - Path Traversal & Injection

pgAdmin 4 < 9.19 contains a path traversal and parameter injection vulnerability caused by improper path resolution and insufficient connection parameter validation, letting attackers access or manipulate other users' files and inject connection parameters, exploit requires crafted server configuration input.

CVSS base score 8.4 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
EPSS
0.18% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Path Traversal
Impact
File System Read, File System Write
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-22

Vendor fix

Upgrade to version 9.19 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs