CVE-2026-116591 compress - Denial of Service

compress < 1.20.2 contains a denial of service caused by integer overflow in zstd DecodeAll and streaming decoder paths, letting attackers crash applications with crafted two-block frames, exploit requires crafted zstd input.

CVSS base score 8.7 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
View the NVD record ↗

Details

Type
Denial of Service
Impact
Denial Of Service
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
26 October 2026
Updated
27 October 2026
Weakness
CWE-190

Vendor fix

Update to version 1.20.2 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs