CVE-2026-116672 Authlib - Broken Access Control

Authlib 0.15 to 1.9.1 contains a broken access control vulnerability caused by improper verification of client credentials in ClientConfigurationEndpoint, letting clients with valid tokens modify or delete other clients' registrations, exploit requires valid registration access token.

CVSS base score 8.8 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
EPSS
0.27% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Broken Access Control
Impact
Broken Access Control, Denial Of Service
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
27 October 2026
Updated
29 October 2026
Weakness
CWE-639

Vendor fix

Update to version 1.9.1 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs