CVE-2026-118205 Essential Addons for Elementor - Privilege Escalation

Essential Addons for Elementor plugin for WordPress <= 6.8.7 contains a privilege escalation caused by improper handling of post status and nonce validation in register_user() function, letting unauthenticated attackers register accounts with elevated roles via crafted revision IDs, exploit requires 'Anyone can register' enabled and prior admin role changes on affected pages.

CVSS base score 7.4 /10
High
CISA KEV
Not listed
Public exploit
None known
EPSS
0.47% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Privilege Escalation
Impact
Privilege Escalation
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-269

Vendor fix

Update to the latest version beyond 6.8.7.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs