CVE-2026-118252 Highcharts JS - Stored XSS

Highcharts JS <= 4.2.3 contains a stored XSS caused by parsing component language strings as HTML in Dashboards edit-mode sidebar, letting attackers execute scripts in the hosting page when users open the sidebar, exploit requires attacker control of language configuration.

CVSS base score 8.4 /10
High
CISA KEV
Not listed
Public exploit
None known
View the NVD record ↗

Details

Type
Stored XSS
Impact
Stored XSS
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:N/SC:L/SI:L/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
28 October 2026
Updated
29 October 2026
Weakness
CWE-79

Vendor fix

Update to version 4.2.3 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs