CVE-2026-118261 Echo - Denial of Service

Echo v4 >= 4.0.0 and < 4.16.1 contains a denial of service caused by unbounded gzip-decoded request stream size in opt-in Decompress middleware, letting attackers exhaust memory or CPU, exploit requires middleware enabled.

CVSS base score 8.2 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
View the NVD record ↗

Details

Type
Denial of Service
Impact
Denial Of Service
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
28 October 2026
Updated
29 October 2026
Weakness
CWE-400

Vendor fix

Update to version 4.16.1 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs