CVE-2026-119977 WordPress Core - Remote Code Execution

WordPress Core 4.7 through 7.1.3 contains a remote code execution caused by predictable, web-accessible staging paths during full-package core upgrades, letting unauthenticated attackers execute code on the server during upgrade window.

CVSS base score 8.1 /10
High
CISA KEV
Exploited in the wild
Public exploit
None known
Authentication
Not required
EPSS
0.60% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Remote Code Execution
Impact
Remote Code Execution
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
Published
31 October 2026
Updated
1 November 2026
Weakness
CWE-367

Vendor fix

Update to a version later than 7.1.3 or the latest available version.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs