---
title: "CVE-2026-119978: Flowise - Command Injection"
description: "Flowise <= 3.1.4 contains a sandbox escape caused by abusing allowlisted langchain and mammoth modules with ALLOW_BUILTIN_DEP=true in /api/v1/node-custom-function, letting authenticated users execute OS commands as the Flowise process user."
url: https://panop.io/threat-heartbeat/CVE-2026-119978/
---

# CVE-2026-119978 Flowise - Command Injection

Flowise <= 3.1.4 contains a sandbox escape caused by abusing allowlisted langchain and mammoth modules with ALLOW\_BUILTIN\_DEP=true in /api/v1/node-custom-function, letting authenticated users execute OS commands as the Flowise process user.

CVSS base score 8.5 /10

High

CISA KEV

Not listed

Public exploit

None known

Authentication

Required

EPSS

0.32% chance of exploitation in 30 days

[View the NVD record ↗](https://nvd.nist.gov/vuln/detail/CVE-2026-119978)

## Details

Type

Command Injection

Impact

Remote Code Execution

CVSS vector

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H

Published

30 October 2026

Updated

1 November 2026

Weakness

[CWE-749](https://cwe.mitre.org/data/definitions/749.html)

## Vendor fix

Update to the latest version beyond 3.1.4 or apply patches that disable unsafe module usage.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

## References

- [https://nvd.nist.gov/vuln/detail/CVE-2026-119978](https://nvd.nist.gov/vuln/detail/CVE-2026-119978)
- [https://github.com/FlowiseAI/Flowise/blob/a65f81bb43ef66d3ce734bf0dff4223ae8041c95/packages/components/src/utils.ts#L1733](https://github.com/FlowiseAI/Flowise/blob/a65f81bb43ef66d3ce734bf0dff4223ae8041c95/packages/components/src/utils.ts#L1733)
- [https://github.com/FlowiseAI/Flowise/blob/a65f81bb43ef66d3ce734bf0dff4223ae8041c95/packages/components/src/utils.ts#L55-L114](https://github.com/FlowiseAI/Flowise/blob/a65f81bb43ef66d3ce734bf0dff4223ae8041c95/packages/components/src/utils.ts#L55-L114)
- [https://github.com/advisories/GHSA-9gvv-qjj3-2p6g](https://github.com/advisories/GHSA-9gvv-qjj3-2p6g)
- [https://www.vulncheck.com/advisories/flowise-through-3.1.4-custom-function-sandbox-escape-rce-via-localfilestore](https://www.vulncheck.com/advisories/flowise-through-3.1.4-custom-function-sandbox-escape-rce-via-localfilestore)
- [https://github.com/FlowiseAI/Flowise](https://github.com/FlowiseAI/Flowise)

[← All CVEs](https://panop.io/threat-heartbeat/)

## What this record can't tell you

- Whether you run the affected software, and where
- Whether an attacker can actually reach and exploit it
- The misconfigurations that never get a CVE number
- What it would cost the business, ranked into what to fix first

Panop answers these inside your environment, for this CVE and every other finding.

[Book a demo](https://panop.io/demo)
