---
title: "CVE-2026-120061: psqlODBC - Buffer Overflow"
description: "psqlODBC before 18.00.0006 contains a buffer overflow caused by improper handling of ODBC escape sequences in SQL text, letting attackers cause memory corruption via crafted SQL queries, exploit requires untrusted SQL input."
url: https://panop.io/threat-heartbeat/CVE-2026-120061/
---

# CVE-2026-120061 psqlODBC - Buffer Overflow

psqlODBC before 18.00.0006 contains a buffer overflow caused by improper handling of ODBC escape sequences in SQL text, letting attackers cause memory corruption via crafted SQL queries, exploit requires untrusted SQL input.

CVSS base score 7.5 /10

High

CISA KEV

Not listed

Public exploit

None known

Authentication

Required

[View the NVD record ↗](https://nvd.nist.gov/vuln/detail/CVE-2026-120061)

## Details

Type

Buffer Overflow

Impact

Remote Code Execution, Denial Of Service

CVSS vector

CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Published

2 November 2026

Updated

3 November 2026

Weakness

[CWE-121](https://cwe.mitre.org/data/definitions/121.html)

## Vendor fix

Update to version 18.00.0006 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

## References

- [https://nvd.nist.gov/vuln/detail/CVE-2026-120061](https://nvd.nist.gov/vuln/detail/CVE-2026-120061)
- [https://github.com/postgresql-interfaces/psqlodbc/security/advisories/GHSA-hfm6-qfx8-v4xq](https://github.com/postgresql-interfaces/psqlodbc/security/advisories/GHSA-hfm6-qfx8-v4xq)

[← All CVEs](https://panop.io/threat-heartbeat/)

## What this record can't tell you

- Whether you run the affected software, and where
- Whether an attacker can actually reach and exploit it
- The misconfigurations that never get a CVE number
- What it would cost the business, ranked into what to fix first

Panop answers these inside your environment, for this CVE and every other finding.

[Book a demo](https://panop.io/demo)
