CVE-2026-57200 Asterisk - Authorization Bypass & Remote Code Execution

Asterisk < 20.20.1, 21.12.3, 22.10.1, 23.4.1 and Certified Asterisk < 22.8-cert3 contain an authorization bypass caused by improper REST-over-WebSocket handling in ARI, letting authenticated attackers with read-only ARI credentials execute write operations and remote code, exploit requires HTTP web server enabled and reachable.

CVSS base score 7.5 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
EPSS
0.88% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Authorization Bypass
Impact
Remote Code Execution
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
27 October 2026
Updated
29 October 2026
Weakness
CWE-22

Vendor fix

Update to versions 20.20.1, 21.12.3, 22.10.1, 23.4.1 or Certified Asterisk 22.8-cert3 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs