CVE-2026-58255 Cronicle - Privilege Escalation

Cronicle < 0.9.121 contains a privilege escalation caused by injection of top-level uid and gid fields via API endpoints, letting non-admin users run jobs as arbitrary users including root, exploit requires non-admin user or scoped API key with create_events and run_events privileges.

CVSS base score 8.8 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
EPSS
0.41% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Privilege Escalation
Impact
Privilege Escalation
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Published
27 October 2026
Updated
29 October 2026
Weakness
CWE-269

Vendor fix

Update to version 0.9.121 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs