CVE-2026-59179 OpenHop @openhop/server - Path Traversal

OpenHop @openhop/server < 0.3.7 contains a path traversal vulnerability caused by lack of identifier allow-list in flow route parameters, letting attackers read or delete YAML files outside the flow directory, exploit requires network access to unauthenticated API endpoints.

CVSS base score 8.3 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
View the NVD record ↗

Details

Type
Path Traversal
Impact
Information Disclosure, File System Write
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:H
Published
28 October 2026
Updated
29 October 2026
Weakness
CWE-22

Vendor fix

Update to version 0.3.7 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs