CVE-2026-62297 ag-psd - Denial of Service

ag-psd before 31.0.0 contains a denial of service caused by unvalidated attacker-declared PSD geometry leading to excessive memory allocation in psdReader.js, letting attackers exhaust memory remotely, exploit requires crafted PSD input.

CVSS base score 7.5 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
EPSS
0.34% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Denial of Service
Impact
Denial Of Service
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-789

Vendor fix

Update to version 31.0.0 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs