CVE-2026-63393 OpenSearch SQL - Remote Code Execution

OpenSearch SQL 2.x >= 2.8.0.0 < 2.19.6.0 and 3.x < 3.7.0.0 contain an insecure deserialization vulnerability caused by unsafe deserialization of untrusted data in the plugins/sql endpoint, letting remote authenticated users with read/search permissions execute arbitrary code on the server, exploit requires authenticated user with read/search permissions.

CVSS base score 8.7 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
EPSS
0.50% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Remote Code Execution
Impact
Remote Code Execution
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-502

Vendor fix

Update to versions 2.19.6.0 or 3.7.0.0 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs