CVE-2026-90437 Gravity Forms - Stored XSS

Gravity Forms WordPress plugin <= 3.1.1 contains a stored cross-site scripting caused by insufficient input sanitization and output escaping in Post Excerpt, Post Custom Field, and Rich-Text Paragraph fields, letting unauthenticated attackers inject and execute arbitrary scripts when users access injected pages.

CVSS base score 7.2 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Not required
EPSS
0.19% chance of exploitation in 30 days
View the NVD record ↗

Details

Type
Stored XSS
Impact
Stored XSS
CVSS vector
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:L/A:N
Published
30 October 2026
Updated
1 November 2026
Weakness
CWE-79

Vendor fix

Update to a version later than 3.1.1 or the latest available version.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs