CVE-2026-93851 Mattermost - Stored XSS & Remote Code Execution

Mattermost 11.9.x <= 11.9.1, 11.8.x <= 11.8.5, 11.7.x <= 11.7.10 contain a stored XSS caused by failure to validate target post ID in Agents plugin's mention reminder, letting authenticated users cause admin browsers to send unintended API requests leading to plugin replacement and server code execution, exploit requires admin interaction.

CVSS base score 8.0 /10
High
CISA KEV
Not listed
Public exploit
None known
Authentication
Required
View the NVD record ↗

Details

Type
Stored XSS
Impact
Remote Code Execution, Client Script Exec
CVSS vector
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:C/C:H/I:H/A:H
Published
28 October 2026
Updated
29 October 2026
Weakness
CWE-22

Vendor fix

Update to a version later than 11.9.1, 11.8.5, or 11.7.10.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs