CVE-2026-94482 Next.js - Denial of Service

Next.js 13.0.0 to <15.5.28 and 16.4.1 contains a denial of service caused by crafted requests targeting App Router applications with Server Actions, letting attackers cause excessive CPU consumption and block request processing, exploit requires App Router with Server Actions.

CVSS base score 8.2 /10
High
CISA KEV
Not listed
Public exploit
None known
View the NVD record ↗

Details

Type
Denial of Service
Impact
Denial Of Service
CVSS vector
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N/E:X/CR:X/IR:X/AR:X/MAV:X/MAC:X/MAT:X/MPR:X/MUI:X/MVC:X/MVI:X/MVA:X/MSC:X/MSI:X/MSA:X/S:X/AU:X/R:X/V:X/RE:X/U:X
Published
22 October 2026
Updated
23 October 2026
Weakness
CWE-770

Vendor fix

Update to versions 15.5.28 or 16.4.1 or later.

Patching closes this CVE. It does not tell you which of your systems run the affected version, or what else is exposed alongside them.

References

← All CVEs